Questions About Unmounting

localhost diskarbitration[number]: could not create "file system unmounted" notification

I have a problem with the hard disk on my iBook. I know the answer in the medium term is "rescue everything you can using target disk mode and replace the damn thing already." In the short term, however, I have a deadline to meet and no time for that, so if there's an easy way to regain the use of my computer I want it! Symptoms: Computer won't start from its hard disk. Diskwarrior says the disk is fine [although I suspect Diskwarrior may have exacerbated a previous problem to get me to this point in the first place]. In single user mode, fsck -f says everything is fine. Then I "mount -uw /" and exit single user, and after a bit of babble about jettisoning kernel linkers, it gets thrown into a loop with thousands of copies of this scrolling off the screen: localhost diskarbitration[number]: could not create "file system unmounted" notification. Google gives me some Darwin source code, which helps me not one jot.
http://ask.metafilter.com/41057/localhost-diskarbitrationnumber-could-not-create-file-system-unmounted-notification

How do you mount unmounted art?

I am looking to purchase some art from ebay that is listed as Acrylic Paint on Canvas(unmounted). How would I go about preparing the canvas for hanging on the wall. My google-fu has failed me and I don't really know of any place locally I could ask. Is it just a matter of making a frame out of wood that goes behind the canvas? Does this mean the canvas will need to be stretched?
http://ask.metafilter.com/45561/How-do-you-mount-unmounted-art

Lazy umount or Unmounting a busy disk in Linux

I have read that it is possible to 'umount' a disk that is otherwise busy by using the 'lazy' option. The manpage has this to say about it:

umount - unmount file systems

-l Lazy unmount. Detach the filesystem from the filesystem hierarchy now, and cleanup all references to the filesystem as soon as it is not busy anymore. This option allows a "busy" filesystem to be unmounted. (Requires kernel 2.4.11 or later.)

But what would be the point in that? I considered why we dismount partitions at all:

  1. To remove the hardware
  2. To perform operations on the filesystem that would be unsafe to do while mounted

In either of these cases, all a 'lazy' unmount serves IMHO is to make it more difficult to determine if the disk really is dismounted and you can actually proceed with these actions. The only application for umount -l seems to be for inexperienced users

http://www.superuser.com/questions/412109/lazy-umount-or-unmounting-a-busy-disk-in-linux

How do I unmount a charging device in Linux?

I have a mobile device attached via USB to a Linux box and wish to unmount it. I ran the command fdisk -l however it does not list a mount point. I then ran the command lsusb which yielded the screenshot below.

enter image description here

I then proceeded to search the /dev/disk/by-id directory and was found the following file

enter image description here

The file is a symbolic link to what appears to be /dev/sdc

enter image description here

Questions

  1. Why does it not appear when I run the command fdisk -l?
  2. How do I unmount it properly without simply yanking the USB cord from the USB port?
http://www.superuser.com/questions/446389/how-do-i-unmount-a-charging-device-in-linux

can't unmount cd image in virtualbox

This is a followup question from Can't save data or settings in VirtualBox

In summary: I can't save any data in my fedora inside of Virtualbox. I went to the devices tab, then cd/dvd devices, then remove disk from virtual drive, and I got the error that it was unable to unmount the cd image. It seems that I did something wrong with my installation. What can I do to fix this issue?

http://www.superuser.com/questions/453524/can-t-unmount-cd-image-in-virtualbox

How to remove shortcuts of drives from desktop without unmounting it in Ubuntu?

I have a doubt in UN-mounting the drives in Linux.

Whenever I open any drives in system its shortcut/image will be shown in the desktop. To remove that I need to right click on it and select unmount.

Then only that shortcut disappears. This always happens. So whenever I open any drive all of them will be there in desktop. What I need is this shouldn't happen. What can I do for that?Can anyone help?

I am using Ubuntu 12.04. Previously I used 10.10 then also same problem was there.

http://www.superuser.com/questions/555713/how-to-remove-shortcuts-of-drives-from-desktop-without-unmounting-it-in-ubuntu

Amazon S3 with s3fs and fuse. script to unmount and mount

Redhat with Fuse 2.4.8
S3FS version 1.59

In addition to: Amazon S3 with s3fs and fuse, transport endpoint is not connected

I would like to make a script to fix the situation. The script will unmount and mount the the directory. the commands i need to use are:
fusermount -u /s3
/usr/bin/s3fs -o allow_other bucketname /s3

For people who familiar with this situation, should I be concerned with something else ? or this is enough ?

http://www.stackoverflow.com/questions/14090105/amazon-s3-with-s3fs-and-fuse-script-to-unmount-and-mount

Is there a way to force an automatic unmount of a volume under some conditions?

Where I work, we have very light security policy which allows users to connect to their personal mail accounts and so on.

Every user is root on his own computer and there is no centralized account management. It's pretty much like all computers where standalone/personal computers on the same local area network.

The only exception is that the sys-admins demand that we put a key in our /root/.ssh/authorized_keys so they can backup our files. Fair enough, except that I'm a bit paranoid.

I have nothing against having mandatory backups (I even agree it is a good thing) but on some occasion, I plug my personal ciphered usb key that contains my personal password database (keepass) and I'd like to avoid that its content gets backuped.

So here is my question:

Is there a way for me to automatically unmount the USB key volume or even better: to delay the root login from an external host until my usb key is unmounted/plugged ?

What wo

http://www.serverfault.com/questions/436909/is-there-a-way-to-force-an-automatic-unmount-of-a-volume-under-some-conditions

Tool for auto mount/unmount external hard drives

I have a simple Ubuntu (12.10) server running with an external HDD attached to it. It is mounted regularly (NTFS) without RAID or so.

Because it is mounted all the time, the hard drives becomes very hot all the time, even when it is not used.

Is there a tool for automatically unmounting external HDs when they are idle and mount them when someone wants to open it? Or maybe there is another technology that can make this HD go to stand-by while mounted?

The last thing I can think of is making a CRON job to unmount and mount it at predefined intervals (during the night), but I'd prefer something more efficient.

http://www.serverfault.com/questions/439455/tool-for-auto-mount-unmount-external-hard-drives

Force unmount of a partition shared through NFS but not used

Not sure if it's better suited for superuser of unix&linux boards, let me know.

We have a server which is one of the main key points of a somehow large architecture. This server has a backup disk which was not used, although it hosted very old backups. So I decided to set it up, and while it was at the beginning a single partition I used fdisk to repartition it the same way as the primary drive (both are identical).

Unfortunately, after the repartitionning fdisk couldn't manage to get the kernel see the new partition table, nor could partrobe, blockdev or sfdisk. All faced the same issue : BLKRRPART: Device or resource busy, though neither lsof nor fuser did show anything using the device. Here I have to mention that I used umount -l to force the unmount before using fdisk (yes, now it seems stupid and I should ha

http://www.serverfault.com/questions/446349/force-unmount-of-a-partition-shared-through-nfs-but-not-used

fsck an active disk provides different results than fsck on an unmounted disk

I have a VM running ubuntu LTS with an ext4 filesystem. We had performance problems that were related to IO tasks. I checked the filesystem with

fsck.ext4 -nv /dev/sda1 e2fsck 1.41.11 (14-Mar-2010)

Warning! /dev/sda1 is mounted.

Warning: skipping journal recovery because doing a read-only filesystem check.

/dev/sda1 contains a file system with errors, check forced.

Pass 1: Checking inodes, blocks, and sizes

Pass 2: Checking directory structure

Entry 'pgstat.stat' in /var/lib/postgresql/8.4/main/pg_stat_tmp (4721210) has deleted/unused inode 4732417. Clear? no

Pass 3: Checking directory connectivity

Pass 4: Checking reference counts

Unattached zero-length inode 2127051. Clear? no

Unattached inode 2127051

Connect to /lost+found? no

Unattached inode 4757639

Connect to /lost+found? no

Pass

http://www.serverfault.com/questions/450249/fsck-an-active-disk-provides-different-results-than-fsck-on-an-unmounted-disk

VMWare 5.1 Datastore in use when trying to unmount?

When trying to unmount a datastore from one of my 4 ESXi hosts, I receive a message that it's in use.

The full error stack I see is:

Call "HostDatastoreSystem.RemoveDatastore" for object "datastoreSystem-57" on vCenter Server "TSD-VCENTER2.jhuapl.edu" failed.

I've tried the following:

  • Removing the datastore from the other three ESXi 5.1 hosts (successful)
  • Running the following PowerCLI script to list all ISOs (there were some):
Get-VM | Get-CDDrive | FT Parent, IsoPath, HostDevice
  • Luckily I didn't need any of them so I did an unmount across the board:
Get-VM | Get-CDDrive | Set-CDDrive -NoMedia -Confirm:$False
  • Ran the first script to list all ISOs again (no host devices or IsoPaths mounted now)
  • Looked for any hard disks that could possibly be poi
http://www.serverfault.com/questions/481516/vmware-5-1-datastore-in-use-when-trying-to-unmount

How to mount and unmount devices remotely from a web service

Don't ask me why, but I have to find a way to allow the Apache user www-data to mount and unmount devices at run-time on the host system. Such devices are, for example, external USB drives on /dev/sdaXY formatted with NTFS filesystem.

I'm running the web service on a Debian machine using Apache 2.2 and PHP 5.3. When I try to run the mount command via PHP's exec() I obviously have these error message:

exec('mount /dev/sda1 /media/usb_flash');
// -> mount: only root can do that

exec('sudo mount /dev/sda1 /media/usb_flash');
// -> sudo: no tty present and no askpass program specified

exec('sudo -n mount /dev/sda1 /media/usb_flash');
// -> sudo: sorry, a password is required to run sudo

I'm aware only root can do that (in fact, from SSH, I always need sudo when mounting) and that www-data cannot be a sudoer. But I'm sure there's a w

http://www.serverfault.com/questions/483860/how-to-mount-and-unmount-devices-remotely-from-a-web-service

Sending HDD to sleep after unmounting it in server running on CentOS Linux?

How to send to sleep a hard drive completely after it's being unmounted?

I'm planning to have separate 4TB drive only for backups. It will be encrypted and I will only mount it when I need to perform big backups. After unmounting it again, I would like to send it to sleep, i.e. physically to make it stop spinning.

Is there a way to do it in CentOS Linux 6.3?

Any help would be appreciated.

http://www.serverfault.com/questions/484081/sending-hdd-to-sleep-after-unmounting-it-in-server-running-on-centos-linux

NFS unmounted folder having cached files?

Even if I unmount an NFS folder will it still have cached copies of those files from unmount time in that folder?

My understanding is NFS folder once unmounted shouldn't have anything under that folder. That is

ls /mountFolder 

should return empty. Where can I find definitive reference regarding this?

In one of our machines after unmount we stil see files in that folder. Is it cached files or files from old non-NFS filesystem which was there?

http://www.serverfault.com/questions/489668/nfs-unmounted-folder-having-cached-files

Azure Cent OS Unmounts my data Drive

I have a Cent OS VM instance running on Windows Azure. I have a 1TB data drive mounted to that VM to hold an application's database files. Every week or so at inconsistent intervals, my database crashes and I find that my data drive has been automatically, and without my permission, unmounted.

My data drive still exists with all the data in tact. I have to log in and remount "sudo mount /dev/sdd1 /mount/datadrive". This is frustrating and harmful to my data and the processes that use it.

What am I doing wrong? Any idea why this is happening? How can i make it stop. THANK YOU.

http://www.serverfault.com/questions/491142/azure-cent-os-unmounts-my-data-drive